From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1755252AbcHBLUG (ORCPT ); Tue, 2 Aug 2016 07:20:06 -0400 Received: from mga02.intel.com ([134.134.136.20]:18378 "EHLO mga02.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1754329AbcHBLTR (ORCPT ); Tue, 2 Aug 2016 07:19:17 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,459,1464678000"; d="scan'208";a="1028246234" From: Baole Ni To: minyard@acm.org, gustavo@padovan.org, johan.hedberg@gmail.com, gregkh@linuxfoundation.org, hpa@zytor.com, x86@kernel.org Cc: openipmi-developer@lists.sourceforge.net, linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com, jslaby@suse.cz, peter@korsgaard.com, lee.jones@linaro.org Subject: [PATCH 0103/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 18:40:53 +0800 Message-Id: <20160802104053.20621-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/char/ipmi/ipmi_poweroff.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/char/ipmi/ipmi_poweroff.c b/drivers/char/ipmi/ipmi_poweroff.c index 9f2e3be..271f978 100644 --- a/drivers/char/ipmi/ipmi_poweroff.c +++ b/drivers/char/ipmi/ipmi_poweroff.c @@ -80,13 +80,13 @@ static int set_param_ifnum(const char *val, struct kernel_param *kp) } module_param_call(ifnum_to_use, set_param_ifnum, param_get_int, - &ifnum_to_use, 0644); + &ifnum_to_use, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(ifnum_to_use, "The interface number to use for the watchdog " "timer. Setting to -1 defaults to the first registered " "interface"); /* parameter definition to allow user to flag power cycle */ -module_param(poweroff_powercycle, int, 0644); +module_param(poweroff_powercycle, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(poweroff_powercycle, " Set to non-zero to enable power cycle instead of power" " down. Power cycle is contingent on hardware support," -- 2.9.2