From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S932106AbcHBL2H (ORCPT ); Tue, 2 Aug 2016 07:28:07 -0400 Received: from mga02.intel.com ([134.134.136.20]:26785 "EHLO mga02.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1754730AbcHBLTR (ORCPT ); Tue, 2 Aug 2016 07:19:17 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,459,1464678000"; d="scan'208";a="1018186705" From: Baole Ni To: minyard@acm.org, gustavo@padovan.org, johan.hedberg@gmail.com, gregkh@linuxfoundation.org, hpa@zytor.com, x86@kernel.org Cc: openipmi-developer@lists.sourceforge.net, linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com, jslaby@suse.cz, peter@korsgaard.com, lee.jones@linaro.org Subject: [PATCH 0104/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 18:40:58 +0800 Message-Id: <20160802104058.20687-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/char/ipmi/ipmi_si_intf.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/char/ipmi/ipmi_si_intf.c b/drivers/char/ipmi/ipmi_si_intf.c index 7b1c412..7cd7fa6 100644 --- a/drivers/char/ipmi/ipmi_si_intf.c +++ b/drivers/char/ipmi/ipmi_si_intf.c @@ -1347,7 +1347,7 @@ static const char * const addr_space_to_str[] = { "i/o", "mem" }; static int hotmod_handler(const char *val, struct kernel_param *kp); -module_param_call(hotmod, hotmod_handler, NULL, NULL, 0200); +module_param_call(hotmod, hotmod_handler, NULL, NULL, S_IWUSR); MODULE_PARM_DESC(hotmod, "Add and remove interfaces. See" " Documentation/IPMI.txt in the kernel sources for the" " gory details."); @@ -1425,7 +1425,7 @@ module_param(unload_when_empty, bool, 0); MODULE_PARM_DESC(unload_when_empty, "Unload the module if no interfaces are" " specified or found, default is 1. Setting to 0" " is useful for hot add of devices using hotmod."); -module_param_array(kipmid_max_busy_us, uint, &num_max_busy_us, 0644); +module_param_array(kipmid_max_busy_us, uint, &num_max_busy_us, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(kipmid_max_busy_us, "Max time (in microseconds) to busy-wait for IPMI data before" " sleeping. 0 (default) means to wait forever. Set to 100-500" -- 2.9.2