From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1755360AbcHBL1z (ORCPT ); Tue, 2 Aug 2016 07:27:55 -0400 Received: from mga09.intel.com ([134.134.136.24]:61343 "EHLO mga09.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1754652AbcHBLTR (ORCPT ); Tue, 2 Aug 2016 07:19:17 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,459,1464678000"; d="scan'208";a="1006926928" From: Baole Ni To: minyard@acm.org, gustavo@padovan.org, johan.hedberg@gmail.com, gregkh@linuxfoundation.org, hpa@zytor.com, x86@kernel.org Cc: openipmi-developer@lists.sourceforge.net, linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com, jslaby@suse.cz, peter@korsgaard.com, lee.jones@linaro.org Subject: [PATCH 0106/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 18:41:07 +0800 Message-Id: <20160802104107.20819-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/char/ipmi/ipmi_watchdog.c | 18 +++++++++--------- 1 file changed, 9 insertions(+), 9 deletions(-) diff --git a/drivers/char/ipmi/ipmi_watchdog.c b/drivers/char/ipmi/ipmi_watchdog.c index 4facc75..9e3241f 100644 --- a/drivers/char/ipmi/ipmi_watchdog.c +++ b/drivers/char/ipmi/ipmi_watchdog.c @@ -285,37 +285,37 @@ static const struct kernel_param_ops param_ops_str = { .get = get_param_str, }; -module_param(ifnum_to_use, wdog_ifnum, 0644); +module_param(ifnum_to_use, wdog_ifnum, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(ifnum_to_use, "The interface number to use for the watchdog " "timer. Setting to -1 defaults to the first registered " "interface"); -module_param(timeout, timeout, 0644); +module_param(timeout, timeout, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(timeout, "Timeout value in seconds."); -module_param(pretimeout, timeout, 0644); +module_param(pretimeout, timeout, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(pretimeout, "Pretimeout value in seconds."); -module_param(panic_wdt_timeout, timeout, 0644); +module_param(panic_wdt_timeout, timeout, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(timeout, "Timeout value on kernel panic in seconds."); -module_param_cb(action, ¶m_ops_str, action_op, 0644); +module_param_cb(action, ¶m_ops_str, action_op, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(action, "Timeout action. One of: " "reset, none, power_cycle, power_off."); -module_param_cb(preaction, ¶m_ops_str, preaction_op, 0644); +module_param_cb(preaction, ¶m_ops_str, preaction_op, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(preaction, "Pretimeout action. One of: " "pre_none, pre_smi, pre_nmi, pre_int."); -module_param_cb(preop, ¶m_ops_str, preop_op, 0644); +module_param_cb(preop, ¶m_ops_str, preop_op, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(preop, "Pretimeout driver operation. One of: " "preop_none, preop_panic, preop_give_data."); -module_param(start_now, int, 0444); +module_param(start_now, int, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(start_now, "Set to 1 to start the watchdog as" "soon as the driver is loaded."); -module_param(nowayout, bool, 0644); +module_param(nowayout, bool, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(nowayout, "Watchdog cannot be stopped once started " "(default=CONFIG_WATCHDOG_NOWAYOUT)"); -- 2.9.2