From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1755412AbcHBLYR (ORCPT ); Tue, 2 Aug 2016 07:24:17 -0400 Received: from mga02.intel.com ([134.134.136.20]:53308 "EHLO mga02.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1754890AbcHBLXO (ORCPT ); Tue, 2 Aug 2016 07:23:14 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,459,1464678000"; d="scan'208";a="1006927646" From: Baole Ni To: herbert@gondor.apana.org.au, davem@davemloft.net, hpa@zytor.com, x86@kernel.org Cc: linux-crypto@vger.kernel.org, linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com, jslaby@suse.cz, peter@korsgaard.com, lee.jones@linaro.org Subject: [PATCH 0128/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 18:42:47 +0800 Message-Id: <20160802104247.22284-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/crypto/hifn_795x.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/crypto/hifn_795x.c b/drivers/crypto/hifn_795x.c index eee2c7e..dfcaa29 100644 --- a/drivers/crypto/hifn_795x.c +++ b/drivers/crypto/hifn_795x.c @@ -33,7 +33,7 @@ #include static char hifn_pll_ref[sizeof("extNNN")] = "ext"; -module_param_string(hifn_pll_ref, hifn_pll_ref, sizeof(hifn_pll_ref), 0444); +module_param_string(hifn_pll_ref, hifn_pll_ref, sizeof(hifn_pll_ref), S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(hifn_pll_ref, "PLL reference clock (pci[freq] or ext[freq], default ext)"); -- 2.9.2