From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1757199AbcHBSSq (ORCPT ); Tue, 2 Aug 2016 14:18:46 -0400 Received: from mga02.intel.com ([134.134.136.20]:64171 "EHLO mga02.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1755443AbcHBL2F (ORCPT ); Tue, 2 Aug 2016 07:28:05 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,459,1464678000"; d="scan'208";a="858086374" From: Baole Ni To: mchehab@kernel.org, maurochehab@gmail.com, mchehab@infradead.org, mchehab@redhat.com, m.chehab@samsung.com, dougthompson@xmission.com, bp@alien8.de Cc: linux-edac@vger.kernel.org, linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com, lee.jones@linaro.org Subject: [PATCH 0138/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 18:43:48 +0800 Message-Id: <20160802104348.22950-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/edac/amd64_edac.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/edac/amd64_edac.c b/drivers/edac/amd64_edac.c index 46784eb..2ebc7a5 100644 --- a/drivers/edac/amd64_edac.c +++ b/drivers/edac/amd64_edac.c @@ -4,14 +4,14 @@ static struct edac_pci_ctl_info *pci_ctl; static int report_gart_errors; -module_param(report_gart_errors, int, 0644); +module_param(report_gart_errors, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); /* * Set by command line parameter. If BIOS has enabled the ECC, this override is * cleared to prevent re-enabling the hardware by this driver. */ static int ecc_enable_override; -module_param(ecc_enable_override, int, 0644); +module_param(ecc_enable_override, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); static struct msr __percpu *msrs; @@ -3037,5 +3037,5 @@ MODULE_AUTHOR("SoftwareBitMaker: Doug Thompson, " MODULE_DESCRIPTION("MC support for AMD64 memory controllers - " EDAC_AMD64_VERSION); -module_param(edac_op_state, int, 0444); +module_param(edac_op_state, int, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(edac_op_state, "EDAC Error Reporting state: 0=Poll,1=NMI"); -- 2.9.2