From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S932218AbcHBLg7 (ORCPT ); Tue, 2 Aug 2016 07:36:59 -0400 Received: from mga11.intel.com ([192.55.52.93]:62470 "EHLO mga11.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1755856AbcHBLgY (ORCPT ); Tue, 2 Aug 2016 07:36:24 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,459,1464678000"; d="scan'208";a="1033566238" From: Baole Ni To: mchehab@kernel.org, maurochehab@gmail.com, mchehab@infradead.org, mchehab@redhat.com, m.chehab@samsung.com, dougthompson@xmission.com, bp@alien8.de Cc: linux-edac@vger.kernel.org, linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com, lee.jones@linaro.org Subject: [PATCH 0142/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 18:44:05 +0800 Message-Id: <20160802104405.23214-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/edac/edac_mc_sysfs.c | 8 ++++---- 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/drivers/edac/edac_mc_sysfs.c b/drivers/edac/edac_mc_sysfs.c index 10c305b..1603b76 100644 --- a/drivers/edac/edac_mc_sysfs.c +++ b/drivers/edac/edac_mc_sysfs.c @@ -74,16 +74,16 @@ static int edac_set_poll_msec(const char *val, struct kernel_param *kp) } /* Parameter declarations for above */ -module_param(edac_mc_panic_on_ue, int, 0644); +module_param(edac_mc_panic_on_ue, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(edac_mc_panic_on_ue, "Panic on uncorrected error: 0=off 1=on"); -module_param(edac_mc_log_ue, int, 0644); +module_param(edac_mc_log_ue, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(edac_mc_log_ue, "Log uncorrectable error to console: 0=off 1=on"); -module_param(edac_mc_log_ce, int, 0644); +module_param(edac_mc_log_ce, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(edac_mc_log_ce, "Log correctable error to console: 0=off 1=on"); module_param_call(edac_mc_poll_msec, edac_set_poll_msec, param_get_int, - &edac_mc_poll_msec, 0644); + &edac_mc_poll_msec, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(edac_mc_poll_msec, "Polling period in milliseconds"); static struct device *mci_pdev; -- 2.9.2