From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1755774AbcHBLao (ORCPT ); Tue, 2 Aug 2016 07:30:44 -0400 Received: from mga03.intel.com ([134.134.136.65]:37438 "EHLO mga03.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1755572AbcHBL3T (ORCPT ); Tue, 2 Aug 2016 07:29:19 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,459,1464678000"; d="scan'208";a="1028247815" From: Baole Ni To: mchehab@kernel.org, maurochehab@gmail.com, mchehab@infradead.org, mchehab@redhat.com, m.chehab@samsung.com, dougthompson@xmission.com, bp@alien8.de Cc: linux-edac@vger.kernel.org, linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com, lee.jones@linaro.org Subject: [PATCH 0143/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 18:44:10 +0800 Message-Id: <20160802104410.23280-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/edac/edac_module.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/edac/edac_module.c b/drivers/edac/edac_module.c index 5f8543b..54009fa 100644 --- a/drivers/edac/edac_module.c +++ b/drivers/edac/edac_module.c @@ -39,7 +39,7 @@ int edac_debug_level = 2; EXPORT_SYMBOL_GPL(edac_debug_level); module_param_call(edac_debug_level, edac_set_debug_level, param_get_int, - &edac_debug_level, 0644); + &edac_debug_level, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(edac_debug_level, "EDAC debug level: [0-4], default: 2"); #endif -- 2.9.2