From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S934372AbcHBMS2 (ORCPT ); Tue, 2 Aug 2016 08:18:28 -0400 Received: from mga11.intel.com ([192.55.52.93]:50822 "EHLO mga11.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S934280AbcHBMRf (ORCPT ); Tue, 2 Aug 2016 08:17:35 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,459,1464678000"; d="scan'208";a="743066558" From: Baole Ni To: mchehab@kernel.org, maurochehab@gmail.com, mchehab@infradead.org, mchehab@redhat.com, m.chehab@samsung.com, dougthompson@xmission.com, bp@alien8.de Cc: linux-edac@vger.kernel.org, linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com, lee.jones@linaro.org Subject: [PATCH 0152/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 18:44:48 +0800 Message-Id: <20160802104448.23875-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/edac/i82860_edac.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/edac/i82860_edac.c b/drivers/edac/i82860_edac.c index ee1078c..ae68efe 100644 --- a/drivers/edac/i82860_edac.c +++ b/drivers/edac/i82860_edac.c @@ -362,5 +362,5 @@ MODULE_AUTHOR("Red Hat Inc. (http://www.redhat.com) " "Ben Woodard "); MODULE_DESCRIPTION("ECC support for Intel 82860 memory hub controllers"); -module_param(edac_op_state, int, 0444); +module_param(edac_op_state, int, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(edac_op_state, "EDAC Error Reporting state: 0=Poll,1=NMI"); -- 2.9.2