From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S936323AbcHBSR1 (ORCPT ); Tue, 2 Aug 2016 14:17:27 -0400 Received: from mga01.intel.com ([192.55.52.88]:53595 "EHLO mga01.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1755399AbcHBL2X (ORCPT ); Tue, 2 Aug 2016 07:28:23 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,459,1464678000"; d="scan'208";a="1033567392" From: Baole Ni To: airlied@linux.ie, alexander.deucher@amd.com, christian.koenig@amd.com, matt@codeblueprint.co.uk, m.chehab@samsung.com, lho@apm.com, dougthompson@xmission.com, bp@alien8.de Cc: dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org, airlied@redhat.com, daniel.vetter@ffwll.ch, emil.l.velikov@gmail.com, chuansheng.liu@intel.com, baolex.ni@intel.com Subject: [PATCH 0181/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 18:47:20 +0800 Message-Id: <20160802104720.25805-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/gpu/drm/ast/ast_drv.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/gpu/drm/ast/ast_drv.c b/drivers/gpu/drm/ast/ast_drv.c index fcd9c07..8c4bee4 100644 --- a/drivers/gpu/drm/ast/ast_drv.c +++ b/drivers/gpu/drm/ast/ast_drv.c @@ -36,7 +36,7 @@ int ast_modeset = -1; MODULE_PARM_DESC(modeset, "Disable/Enable modesetting"); -module_param_named(modeset, ast_modeset, int, 0400); +module_param_named(modeset, ast_modeset, int, S_IRUSR); #define PCI_VENDOR_ASPEED 0x1a03 -- 2.9.2