From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1755371AbcHBL3z (ORCPT ); Tue, 2 Aug 2016 07:29:55 -0400 Received: from mga14.intel.com ([192.55.52.115]:1959 "EHLO mga14.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1753947AbcHBL2z (ORCPT ); Tue, 2 Aug 2016 07:28:55 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,459,1464678000"; d="scan'208";a="1006929772" From: Baole Ni To: airlied@linux.ie, alexander.deucher@amd.com, christian.koenig@amd.com, matt@codeblueprint.co.uk, m.chehab@samsung.com, lho@apm.com, dougthompson@xmission.com, bp@alien8.de Cc: dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com, robbat2@gentoo.org, mst@redhat.com, tiwai@suse.de, architt@codeaurora.org Subject: [PATCH 0189/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 18:48:06 +0800 Message-Id: <20160802104806.26353-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/gpu/drm/drm_fb_helper.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/gpu/drm/drm_fb_helper.c b/drivers/gpu/drm/drm_fb_helper.c index 7c2eb75..3f15327 100644 --- a/drivers/gpu/drm/drm_fb_helper.c +++ b/drivers/gpu/drm/drm_fb_helper.c @@ -42,7 +42,7 @@ #include static bool drm_fbdev_emulation = true; -module_param_named(fbdev_emulation, drm_fbdev_emulation, bool, 0600); +module_param_named(fbdev_emulation, drm_fbdev_emulation, bool, S_IRUSR | S_IWUSR); MODULE_PARM_DESC(fbdev_emulation, "Enable legacy fbdev emulation [default=true]"); -- 2.9.2