From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S936343AbcHBSRp (ORCPT ); Tue, 2 Aug 2016 14:17:45 -0400 Received: from mga02.intel.com ([134.134.136.20]:52244 "EHLO mga02.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1755429AbcHBL2V (ORCPT ); Tue, 2 Aug 2016 07:28:21 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,459,1464678000"; d="scan'208";a="743067479" From: Baole Ni To: airlied@linux.ie, alexander.deucher@amd.com, christian.koenig@amd.com, matt@codeblueprint.co.uk, m.chehab@samsung.com, lho@apm.com, dougthompson@xmission.com, bp@alien8.de Cc: dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com, robbat2@gentoo.org, mst@redhat.com, tiwai@suse.de, architt@codeaurora.org Subject: [PATCH 0190/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 18:48:11 +0800 Message-Id: <20160802104811.26419-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/gpu/drm/drm_irq.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/gpu/drm/drm_irq.c b/drivers/gpu/drm/drm_irq.c index 0fac801c..c1c0fd9 100644 --- a/drivers/gpu/drm/drm_irq.c +++ b/drivers/gpu/drm/drm_irq.c @@ -70,9 +70,9 @@ unsigned int drm_timestamp_monotonic = 1; static int drm_vblank_offdelay = 5000; /* Default to 5000 msecs. */ -module_param_named(vblankoffdelay, drm_vblank_offdelay, int, 0600); -module_param_named(timestamp_precision_usec, drm_timestamp_precision, int, 0600); -module_param_named(timestamp_monotonic, drm_timestamp_monotonic, int, 0600); +module_param_named(vblankoffdelay, drm_vblank_offdelay, int, S_IRUSR | S_IWUSR); +module_param_named(timestamp_precision_usec, drm_timestamp_precision, int, S_IRUSR | S_IWUSR); +module_param_named(timestamp_monotonic, drm_timestamp_monotonic, int, S_IRUSR | S_IWUSR); MODULE_PARM_DESC(vblankoffdelay, "Delay until vblank irq auto-disable [msecs] (0: never disable, <0: disable immediately)"); MODULE_PARM_DESC(timestamp_precision_usec, "Max. error on timestamps [usecs]"); MODULE_PARM_DESC(timestamp_monotonic, "Use monotonic timestamps"); -- 2.9.2