From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1757020AbcHBSXj (ORCPT ); Tue, 2 Aug 2016 14:23:39 -0400 Received: from mga03.intel.com ([134.134.136.65]:51235 "EHLO mga03.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1755440AbcHBL2F (ORCPT ); Tue, 2 Aug 2016 07:28:05 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,459,1464678000"; d="scan'208";a="1033567805" From: Baole Ni To: airlied@linux.ie, alexander.deucher@amd.com, christian.koenig@amd.com, matt@codeblueprint.co.uk, m.chehab@samsung.com, lho@apm.com, dougthompson@xmission.com, bp@alien8.de Cc: dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com, robbat2@gentoo.org, mst@redhat.com, tiwai@suse.de, architt@codeaurora.org Subject: [PATCH 0191/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 18:48:16 +0800 Message-Id: <20160802104816.26485-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/gpu/drm/drm_probe_helper.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/gpu/drm/drm_probe_helper.c b/drivers/gpu/drm/drm_probe_helper.c index 0329080..8fa1d7b 100644 --- a/drivers/gpu/drm/drm_probe_helper.c +++ b/drivers/gpu/drm/drm_probe_helper.c @@ -59,7 +59,7 @@ */ static bool drm_kms_helper_poll = true; -module_param_named(poll, drm_kms_helper_poll, bool, 0600); +module_param_named(poll, drm_kms_helper_poll, bool, S_IRUSR | S_IWUSR); static enum drm_mode_status drm_mode_validate_flag(const struct drm_display_mode *mode, -- 2.9.2