From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1755720AbcHBLab (ORCPT ); Tue, 2 Aug 2016 07:30:31 -0400 Received: from mga11.intel.com ([192.55.52.93]:14032 "EHLO mga11.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1755595AbcHBL3T (ORCPT ); Tue, 2 Aug 2016 07:29:19 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,459,1464678000"; d="scan'208";a="1033568047" From: Baole Ni To: patrik.r.jakobsson@gmail.com, airlied@linux.ie, sw0312.kim@samsung.com, kyungmin.park@samsung.com, kgene@kernel.org, k.kozlowski@samsung.com, dougthompson@xmission.com, bp@alien8.de Cc: dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com, tiwai@suse.de, architt@codeaurora.org Subject: [PATCH 0195/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 18:48:36 +0800 Message-Id: <20160802104836.26752-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/gpu/drm/gma500/mdfld_dsi_output.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/gpu/drm/gma500/mdfld_dsi_output.c b/drivers/gpu/drm/gma500/mdfld_dsi_output.c index 907cb51..67b5d18 100644 --- a/drivers/gpu/drm/gma500/mdfld_dsi_output.c +++ b/drivers/gpu/drm/gma500/mdfld_dsi_output.c @@ -39,7 +39,7 @@ static int LABC_control = 1; #ifdef MODULE -module_param(LABC_control, int, 0644); +module_param(LABC_control, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); #else static int __init parse_LABC_control(char *arg) -- 2.9.2