From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S936286AbcHBSRE (ORCPT ); Tue, 2 Aug 2016 14:17:04 -0400 Received: from mga04.intel.com ([192.55.52.120]:57315 "EHLO mga04.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1755422AbcHBL23 (ORCPT ); Tue, 2 Aug 2016 07:28:29 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,459,1464678000"; d="scan'208";a="743067840" From: Baole Ni To: airlied@linux.ie, kyungmin.park@samsung.com, kgene@kernel.org, k.kozlowski@samsung.com, dougthompson@xmission.com, bp@alien8.de Cc: dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org, tomi.valkeinen@ti.com, laurent.pinchart@ideasonboard.com, daniel.vetter@ffwll.ch, architt@codeaurora.org, chuansheng.liu@intel.com, baolex.ni@intel.com Subject: [PATCH 0209/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 18:49:55 +0800 Message-Id: <20160802104955.27691-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/gpu/drm/omapdrm/omap_fbdev.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/gpu/drm/omapdrm/omap_fbdev.c b/drivers/gpu/drm/omapdrm/omap_fbdev.c index 89da41a..2f27751 100644 --- a/drivers/gpu/drm/omapdrm/omap_fbdev.c +++ b/drivers/gpu/drm/omapdrm/omap_fbdev.c @@ -24,7 +24,7 @@ MODULE_PARM_DESC(ywrap, "Enable ywrap scrolling (omap44xx and later, default 'y')"); static bool ywrap_enabled = true; -module_param_named(ywrap, ywrap_enabled, bool, 0644); +module_param_named(ywrap, ywrap_enabled, bool, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); /* * fbdev funcs, to implement legacy fbdev interface on top of drm driver -- 2.9.2