From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1757253AbcHBSYY (ORCPT ); Tue, 2 Aug 2016 14:24:24 -0400 Received: from mga11.intel.com ([192.55.52.93]:41021 "EHLO mga11.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1755414AbcHBL2F (ORCPT ); Tue, 2 Aug 2016 07:28:05 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,459,1464678000"; d="scan'208";a="1033568571" From: Baole Ni To: airlied@linux.ie, kyungmin.park@samsung.com, kgene@kernel.org, k.kozlowski@samsung.com, dougthompson@xmission.com, bp@alien8.de Cc: dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org, airlied@redhat.com, daniel.vetter@ffwll.ch, treding@nvidia.com, alexander.deucher@amd.com, ville.syrjala@linux.intel.com, chuansheng.liu@intel.com, baolex.ni@intel.com Subject: [PATCH 0210/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 18:50:01 +0800 Message-Id: <20160802105001.27759-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/gpu/drm/qxl/qxl_drv.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/gpu/drm/qxl/qxl_drv.c b/drivers/gpu/drm/qxl/qxl_drv.c index dc9df5f..f62a099 100644 --- a/drivers/gpu/drm/qxl/qxl_drv.c +++ b/drivers/gpu/drm/qxl/qxl_drv.c @@ -51,10 +51,10 @@ static int qxl_modeset = -1; int qxl_num_crtc = 4; MODULE_PARM_DESC(modeset, "Disable/Enable modesetting"); -module_param_named(modeset, qxl_modeset, int, 0400); +module_param_named(modeset, qxl_modeset, int, S_IRUSR); MODULE_PARM_DESC(num_heads, "Number of virtual crtcs to expose (default 4)"); -module_param_named(num_heads, qxl_num_crtc, int, 0400); +module_param_named(num_heads, qxl_num_crtc, int, S_IRUSR); static struct drm_driver qxl_driver; static struct pci_driver qxl_pci_driver; -- 2.9.2