From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1757167AbcHBSHt (ORCPT ); Tue, 2 Aug 2016 14:07:49 -0400 Received: from mga14.intel.com ([192.55.52.115]:38789 "EHLO mga14.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S932209AbcHBLaR (ORCPT ); Tue, 2 Aug 2016 07:30:17 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="858092176" From: Baole Ni To: alexander.shishkin@linux.intel.com, jdelvare@suse.com, linux@roeck-us.net, airlied@linux.ie, kgene@kernel.org, k.kozlowski@samsung.com, dougthompson@xmission.com, bp@alien8.de Cc: linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com, aduggan@synaptics.com, dianders@chromium.org Subject: [PATCH 0242/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 18:52:36 +0800 Message-Id: <20160802105236.29876-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/hwtracing/stm/dummy_stm.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/hwtracing/stm/dummy_stm.c b/drivers/hwtracing/stm/dummy_stm.c index a86612d..7c82ae2 100644 --- a/drivers/hwtracing/stm/dummy_stm.c +++ b/drivers/hwtracing/stm/dummy_stm.c @@ -46,11 +46,11 @@ static struct stm_data dummy_stm[DUMMY_STM_MAX]; static int nr_dummies = 4; -module_param(nr_dummies, int, 0400); +module_param(nr_dummies, int, S_IRUSR); static unsigned int fail_mode; -module_param(fail_mode, int, 0600); +module_param(fail_mode, int, S_IRUSR | S_IWUSR); static int dummy_stm_link(struct stm_data *data, unsigned int master, unsigned int channel) -- 2.9.2