From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S932556AbcHBSCl (ORCPT ); Tue, 2 Aug 2016 14:02:41 -0400 Received: from mga11.intel.com ([192.55.52.93]:45444 "EHLO mga11.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1754254AbcHBLgZ (ORCPT ); Tue, 2 Aug 2016 07:36:25 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="858092685" From: Baole Ni To: andrew.d.henroid@intel.com, davem@davemloft.net, linux@roeck-us.net, airlied@linux.ie, kgene@kernel.org, k.kozlowski@samsung.com, dougthompson@xmission.com, bp@alien8.de Cc: linux-pm@vger.kernel.org, linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com, aduggan@synaptics.com, dianders@chromium.org Subject: [PATCH 0250/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 18:53:15 +0800 Message-Id: <20160802105315.30405-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/idle/i7300_idle.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/idle/i7300_idle.c b/drivers/idle/i7300_idle.c index ffeebc7..26d3e66 100644 --- a/drivers/idle/i7300_idle.c +++ b/drivers/idle/i7300_idle.c @@ -39,11 +39,11 @@ #define MAX_STOP_RETRIES 10 static int debug; -module_param_named(debug, debug, uint, 0644); +module_param_named(debug, debug, uint, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(debug, "Enable debug printks in this driver"); static int forceload; -module_param_named(forceload, forceload, uint, 0644); +module_param_named(forceload, forceload, uint, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(debug, "Enable driver testing on unvalidated i5000"); #define dprintk(fmt, arg...) \ @@ -58,7 +58,7 @@ MODULE_PARM_DESC(debug, "Enable driver testing on unvalidated i5000"); */ #define MAX_THROTTLE_LOW_LIMIT 168 static uint throttle_low_limit = 1; -module_param_named(throttle_low_limit, throttle_low_limit, uint, 0644); +module_param_named(throttle_low_limit, throttle_low_limit, uint, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(throttle_low_limit, "Value for THRTLOWLM activation field " "(0 = disable throttle, 1 = Max throttle, 168 = Min throttle)"); -- 2.9.2