From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1755742AbcHBLjB (ORCPT ); Tue, 2 Aug 2016 07:39:01 -0400 Received: from mga11.intel.com ([192.55.52.93]:43413 "EHLO mga11.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1755609AbcHBLgq (ORCPT ); Tue, 2 Aug 2016 07:36:46 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="858094001" From: Baole Ni To: dledford@redhat.com, sean.hefty@intel.com, hal.rosenstock@gmail.com, bp@alien8.de Cc: linux-rdma@vger.kernel.org, linux-kernel@vger.kernel.org, leon@kernel.org, bart.vanassche@sandisk.com, markb@mellanox.com, mugunthanvnm@ti.com, hans.westgaard.ry@oracle.com, eli@mellanox.com, clsoto@linux.vnet.ibm.com, fw@strlen.de, bigeasy@linutronix.de, chuansheng.liu@intel.com, baolex.ni@intel.com Subject: [PATCH 0268/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 18:55:01 +0800 Message-Id: <20160802105501.31614-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/infiniband/ulp/ipoib/ipoib_ib.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/infiniband/ulp/ipoib/ipoib_ib.c b/drivers/infiniband/ulp/ipoib/ipoib_ib.c index dc6d241..0f25847 100644 --- a/drivers/infiniband/ulp/ipoib/ipoib_ib.c +++ b/drivers/infiniband/ulp/ipoib/ipoib_ib.c @@ -46,7 +46,7 @@ #ifdef CONFIG_INFINIBAND_IPOIB_DEBUG_DATA static int data_debug_level; -module_param(data_debug_level, int, 0644); +module_param(data_debug_level, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(data_debug_level, "Enable data path debug tracing if > 0"); #endif -- 2.9.2