From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S932951AbcHBMBx (ORCPT ); Tue, 2 Aug 2016 08:01:53 -0400 Received: from mga09.intel.com ([134.134.136.24]:1791 "EHLO mga09.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S932777AbcHBMA7 (ORCPT ); Tue, 2 Aug 2016 08:00:59 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="1018192854" From: Baole Ni To: dledford@redhat.com, sean.hefty@intel.com, hal.rosenstock@gmail.com, bp@alien8.de Cc: linux-rdma@vger.kernel.org, linux-kernel@vger.kernel.org, leon@kernel.org, cl@linux.com, erezsh@mellanox.com, haggaie@mellanox.com, markb@mellanox.com, matanb@mellanox.com, eli@mellanox.com, guysh@mellanox.com, ogerlitz@mellanox.com, chuansheng.liu@intel.com, baolex.ni@intel.com Subject: [PATCH 0269/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 18:55:08 +0800 Message-Id: <20160802105508.31682-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/infiniband/ulp/ipoib/ipoib_main.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/infiniband/ulp/ipoib/ipoib_main.c b/drivers/infiniband/ulp/ipoib/ipoib_main.c index 5f58c41..eed3e3c 100644 --- a/drivers/infiniband/ulp/ipoib/ipoib_main.c +++ b/drivers/infiniband/ulp/ipoib/ipoib_main.c @@ -65,15 +65,15 @@ MODULE_VERSION(DRV_VERSION); int ipoib_sendq_size __read_mostly = IPOIB_TX_RING_SIZE; int ipoib_recvq_size __read_mostly = IPOIB_RX_RING_SIZE; -module_param_named(send_queue_size, ipoib_sendq_size, int, 0444); +module_param_named(send_queue_size, ipoib_sendq_size, int, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(send_queue_size, "Number of descriptors in send queue"); -module_param_named(recv_queue_size, ipoib_recvq_size, int, 0444); +module_param_named(recv_queue_size, ipoib_recvq_size, int, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(recv_queue_size, "Number of descriptors in receive queue"); #ifdef CONFIG_INFINIBAND_IPOIB_DEBUG int ipoib_debug_level; -module_param_named(debug_level, ipoib_debug_level, int, 0644); +module_param_named(debug_level, ipoib_debug_level, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(debug_level, "Enable debug tracing if > 0"); #endif -- 2.9.2