From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S968170AbcHBRhh (ORCPT ); Tue, 2 Aug 2016 13:37:37 -0400 Received: from mga09.intel.com ([134.134.136.24]:10792 "EHLO mga09.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S932304AbcHBLoJ (ORCPT ); Tue, 2 Aug 2016 07:44:09 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="743069770" From: Baole Ni To: dledford@redhat.com, sean.hefty@intel.com, hal.rosenstock@gmail.com, bp@alien8.de Cc: linux-rdma@vger.kernel.org, linux-kernel@vger.kernel.org, bart.vanassche@sandisk.com, sagig@mellanox.com, alex.estrin@intel.com, nab@linux-iscsi.org, haggaie@mellanox.com, chuansheng.liu@intel.com, baolex.ni@intel.com Subject: [PATCH 0273/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 18:55:33 +0800 Message-Id: <20160802105533.31950-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/infiniband/ulp/srpt/ib_srpt.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/infiniband/ulp/srpt/ib_srpt.c b/drivers/infiniband/ulp/srpt/ib_srpt.c index e68b20cb..291334e 100644 --- a/drivers/infiniband/ulp/srpt/ib_srpt.c +++ b/drivers/infiniband/ulp/srpt/ib_srpt.c @@ -71,12 +71,12 @@ static DEFINE_SPINLOCK(srpt_dev_lock); /* Protects srpt_dev_list. */ static LIST_HEAD(srpt_dev_list); /* List of srpt_device structures. */ static unsigned srp_max_req_size = DEFAULT_MAX_REQ_SIZE; -module_param(srp_max_req_size, int, 0444); +module_param(srp_max_req_size, int, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(srp_max_req_size, "Maximum size of SRP request messages in bytes."); static int srpt_srq_size = DEFAULT_SRPT_SRQ_SIZE; -module_param(srpt_srq_size, int, 0444); +module_param(srpt_srq_size, int, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(srpt_srq_size, "Shared receive queue (SRQ) size."); @@ -85,7 +85,7 @@ static int srpt_get_u64_x(char *buffer, struct kernel_param *kp) return sprintf(buffer, "0x%016llx", *(u64 *)kp->arg); } module_param_call(srpt_service_guid, NULL, srpt_get_u64_x, &srpt_service_guid, - 0444); + S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(srpt_service_guid, "Using this value for ioc_guid, id_ext, and cm_listen_id" " instead of using the node_guid of the first HCA."); -- 2.9.2