From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1755923AbcHBLgd (ORCPT ); Tue, 2 Aug 2016 07:36:33 -0400 Received: from mga01.intel.com ([192.55.52.88]:42143 "EHLO mga01.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1755841AbcHBLgY (ORCPT ); Tue, 2 Aug 2016 07:36:24 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="743070394" From: Baole Ni To: dmitry.torokhov@gmail.com, hal.rosenstock@gmail.com, dledford@redhat.com, sean.hefty@intel.com, bp@alien8.de Cc: linux-input@vger.kernel.org, linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com, jkosina@suse.com Subject: [PATCH 0294/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 18:57:37 +0800 Message-Id: <20160802105737.977-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/input/touchscreen/ucb1400_ts.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/input/touchscreen/ucb1400_ts.c b/drivers/input/touchscreen/ucb1400_ts.c index c1e23cf..c441acc 100644 --- a/drivers/input/touchscreen/ucb1400_ts.c +++ b/drivers/input/touchscreen/ucb1400_ts.c @@ -447,14 +447,14 @@ static struct platform_driver ucb1400_ts_driver = { }; module_platform_driver(ucb1400_ts_driver); -module_param(adcsync, bool, 0444); +module_param(adcsync, bool, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(adcsync, "Synchronize touch readings with ADCSYNC pin."); -module_param(ts_delay, int, 0444); +module_param(ts_delay, int, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(ts_delay, "Delay between panel setup and" " position read. Default = 55us."); -module_param(ts_delay_pressure, int, 0444); +module_param(ts_delay_pressure, int, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(ts_delay_pressure, "delay between panel setup and pressure read." " Default = 0us."); -- 2.9.2