From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S966500AbcHBNgP (ORCPT ); Tue, 2 Aug 2016 09:36:15 -0400 Received: from mga11.intel.com ([192.55.52.93]:37850 "EHLO mga11.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S966366AbcHBNdo (ORCPT ); Tue, 2 Aug 2016 09:33:44 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="1028253660" From: Baole Ni To: rpurdie@rpsys.net, j.anaszewski@samsung.com, hal.rosenstock@gmail.com, dledford@redhat.com, sean.hefty@intel.com, bp@alien8.de Cc: lguest@lists.ozlabs.org, linux-kernel@vger.kernel.org, rusty@rustcorp.com.au, mingo@kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com Subject: [PATCH 0309/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 18:58:54 +0800 Message-Id: <20160802105854.2073-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/lguest/interrupts_and_traps.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/lguest/interrupts_and_traps.c b/drivers/lguest/interrupts_and_traps.c index 67392b6..ebd3723 100644 --- a/drivers/lguest/interrupts_and_traps.c +++ b/drivers/lguest/interrupts_and_traps.c @@ -21,7 +21,7 @@ /* Allow Guests to use a non-128 (ie. non-Linux) syscall trap. */ static unsigned int syscall_vector = IA32_SYSCALL_VECTOR; -module_param(syscall_vector, uint, 0444); +module_param(syscall_vector, uint, S_IRUSR | S_IRGRP | S_IROTH); /* The address of the interrupt handler is split into two bits: */ static unsigned long idt_address(u32 lo, u32 hi) -- 2.9.2