From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1756409AbcHBLlf (ORCPT ); Tue, 2 Aug 2016 07:41:35 -0400 Received: from mga11.intel.com ([192.55.52.93]:48053 "EHLO mga11.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1756149AbcHBLis (ORCPT ); Tue, 2 Aug 2016 07:38:48 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="858098086" From: Baole Ni To: mchehab@kernel.org, maurochehab@gmail.com, mchehab@infradead.org, mchehab@redhat.com, m.chehab@samsung.com, hverkuil@xs4all.nl, hal.rosenstock@gmail.com, bp@alien8.de Cc: linux-media@vger.kernel.org, linux-kernel@vger.kernel.org, chehabrafael@gmail.com, k.kozlowski@samsung.com, shuahkh@osg.samsung.com, chuansheng.liu@intel.com, baolex.ni@intel.com Subject: [PATCH 0329/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 19:00:44 +0800 Message-Id: <20160802110044.3623-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/media/dvb-frontends/au8522_decoder.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/media/dvb-frontends/au8522_decoder.c b/drivers/media/dvb-frontends/au8522_decoder.c index add2463..5db134b 100644 --- a/drivers/media/dvb-frontends/au8522_decoder.c +++ b/drivers/media/dvb-frontends/au8522_decoder.c @@ -45,7 +45,7 @@ MODULE_LICENSE("GPL"); static int au8522_analog_debug; -module_param_named(analog_debug, au8522_analog_debug, int, 0644); +module_param_named(analog_debug, au8522_analog_debug, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(analog_debug, "Analog debugging messages [0=Off (default) 1=On]"); -- 2.9.2