From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S935893AbcHBRdp (ORCPT ); Tue, 2 Aug 2016 13:33:45 -0400 Received: from mga09.intel.com ([134.134.136.24]:51409 "EHLO mga09.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S932350AbcHBLoW (ORCPT ); Tue, 2 Aug 2016 07:44:22 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="1006937147" From: Baole Ni To: mchehab@kernel.org, maurochehab@gmail.com, mchehab@infradead.org, mchehab@redhat.com, m.chehab@samsung.com, crope@iki.fi, hal.rosenstock@gmail.com, bp@alien8.de Cc: linux-media@vger.kernel.org, linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com Subject: [PATCH 0369/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 19:04:50 +0800 Message-Id: <20160802110450.6349-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/media/dvb-frontends/rtl2832_sdr.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/media/dvb-frontends/rtl2832_sdr.c b/drivers/media/dvb-frontends/rtl2832_sdr.c index 47a480a..3f25ba6 100644 --- a/drivers/media/dvb-frontends/rtl2832_sdr.c +++ b/drivers/media/dvb-frontends/rtl2832_sdr.c @@ -38,7 +38,7 @@ #include static bool rtl2832_sdr_emulated_fmt; -module_param_named(emulated_formats, rtl2832_sdr_emulated_fmt, bool, 0644); +module_param_named(emulated_formats, rtl2832_sdr_emulated_fmt, bool, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(emulated_formats, "enable emulated formats (disappears in future)"); /* Original macro does not contain enough null pointer checks for our need */ -- 2.9.2