From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S932447AbcHBLpA (ORCPT ); Tue, 2 Aug 2016 07:45:00 -0400 Received: from mga14.intel.com ([192.55.52.115]:38516 "EHLO mga14.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S932369AbcHBLob (ORCPT ); Tue, 2 Aug 2016 07:44:31 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="1033575121" From: Baole Ni To: mchehab@kernel.org, maurochehab@gmail.com, mchehab@infradead.org, mchehab@redhat.com, m.chehab@samsung.com, crope@iki.fi, hal.rosenstock@gmail.com, bp@alien8.de Cc: linux-media@vger.kernel.org, linux-kernel@vger.kernel.org, mkrufky@linuxtv.org, chuansheng.liu@intel.com, baolex.ni@intel.com, standby24x7@gmail.com Subject: [PATCH 0385/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 19:06:33 +0800 Message-Id: <20160802110633.7441-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/media/dvb-frontends/stv0900_core.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/media/dvb-frontends/stv0900_core.c b/drivers/media/dvb-frontends/stv0900_core.c index f667005..f58ea48 100644 --- a/drivers/media/dvb-frontends/stv0900_core.c +++ b/drivers/media/dvb-frontends/stv0900_core.c @@ -35,7 +35,7 @@ #include "stv0900_init.h" int stvdebug = 1; -module_param_named(debug, stvdebug, int, 0644); +module_param_named(debug, stvdebug, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); /* internal params node */ struct stv0900_inode { -- 2.9.2