From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S933663AbcHBQpF (ORCPT ); Tue, 2 Aug 2016 12:45:05 -0400 Received: from mga09.intel.com ([134.134.136.24]:7892 "EHLO mga09.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S933410AbcHBMAv (ORCPT ); Tue, 2 Aug 2016 08:00:51 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="743077693" From: Baole Ni To: mchehab@kernel.org, maurochehab@gmail.com, mchehab@infradead.org, mchehab@redhat.com, m.chehab@samsung.com, hverkuil@xs4all.nl, s.nawrocki@samsung.com, kgene@kernel.org, k.kozlowski@samsung.com Cc: linux-media@vger.kernel.org, linux-kernel@vger.kernel.org, dan.carpenter@oracle.com, hans.verkuil@cisco.com, chuansheng.liu@intel.com, baolex.ni@intel.com, niklas.soderlund+renesas@ragnatech.se Subject: [PATCH 0548/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 19:23:07 +0800 Message-Id: <20160802112307.18501-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/media/radio/wl128x/fmdrv_common.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/media/radio/wl128x/fmdrv_common.c b/drivers/media/radio/wl128x/fmdrv_common.c index 3f9e6df..9f80411 100644 --- a/drivers/media/radio/wl128x/fmdrv_common.c +++ b/drivers/media/radio/wl128x/fmdrv_common.c @@ -67,12 +67,12 @@ MODULE_PARM_DESC(default_radio_region, "Region: 0=Europe/US, 1=Japan"); /* RDS buffer blocks */ static u32 default_rds_buf = 300; -module_param(default_rds_buf, uint, 0444); +module_param(default_rds_buf, uint, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(default_rds_buf, "RDS buffer entries"); /* Radio Nr */ static u32 radio_nr = -1; -module_param(radio_nr, int, 0444); +module_param(radio_nr, int, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(radio_nr, "Radio Nr"); /* FM irq handlers forward declaration */ -- 2.9.2