From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753626AbcHBPJQ (ORCPT ); Tue, 2 Aug 2016 11:09:16 -0400 Received: from mga03.intel.com ([134.134.136.65]:5237 "EHLO mga03.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S934991AbcHBMfV (ORCPT ); Tue, 2 Aug 2016 08:35:21 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="1006947981" From: Baole Ni To: mchehab@kernel.org, maurochehab@gmail.com, mchehab@infradead.org, mchehab@redhat.com, m.chehab@samsung.com, mkrufky@linuxtv.org, s.nawrocki@samsung.com, kgene@kernel.org, k.kozlowski@samsung.com Cc: linux-media@vger.kernel.org, linux-kernel@vger.kernel.org, nsugino@3way.com.ar, aletorrado@gmail.com, chuansheng.liu@intel.com, baolex.ni@intel.com Subject: [PATCH 0601/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 19:28:36 +0800 Message-Id: <20160802112836.22097-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/media/usb/dvb-usb/dib0700_devices.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/media/usb/dvb-usb/dib0700_devices.c b/drivers/media/usb/dvb-usb/dib0700_devices.c index 0857b56..757b7bf 100644 --- a/drivers/media/usb/dvb-usb/dib0700_devices.c +++ b/drivers/media/usb/dvb-usb/dib0700_devices.c @@ -25,7 +25,7 @@ #include "mxl5007t.h" static int force_lna_activation; -module_param(force_lna_activation, int, 0644); +module_param(force_lna_activation, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(force_lna_activation, "force the activation of Low-Noise-Amplifyer(s) (LNA), " "if applicable for the device (default: 0=automatic/off)."); -- 2.9.2