From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S934166AbcHBMMz (ORCPT ); Tue, 2 Aug 2016 08:12:55 -0400 Received: from mga04.intel.com ([192.55.52.120]:32738 "EHLO mga04.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1756491AbcHBMJj (ORCPT ); Tue, 2 Aug 2016 08:09:39 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="149309012" From: Baole Ni To: mchehab@kernel.org, maurochehab@gmail.com, mchehab@infradead.org, mchehab@redhat.com, m.chehab@samsung.com, hdegoede@redhat.com, kgene@kernel.org, k.kozlowski@samsung.com Cc: linux-media@vger.kernel.org, linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com Subject: [PATCH 0635/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 19:31:52 +0800 Message-Id: <20160802113152.24375-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/media/usb/gspca/xirlink_cit.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/media/usb/gspca/xirlink_cit.c b/drivers/media/usb/gspca/xirlink_cit.c index d5ed9d3..fcbbed8 100644 --- a/drivers/media/usb/gspca/xirlink_cit.c +++ b/drivers/media/usb/gspca/xirlink_cit.c @@ -46,7 +46,7 @@ MODULE_PARM_DESC(ibm_netcam_pro, /* FIXME this should be handled through the V4L2 input selection API */ static int rca_input; -module_param(rca_input, int, 0644); +module_param(rca_input, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(rca_input, "Use rca input instead of ccd sensor on Model 3 cams"); -- 2.9.2