From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S935328AbcHBQ0R (ORCPT ); Tue, 2 Aug 2016 12:26:17 -0400 Received: from mga02.intel.com ([134.134.136.20]:32112 "EHLO mga02.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S934059AbcHBMMA (ORCPT ); Tue, 2 Aug 2016 08:12:00 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="1028270081" From: Baole Ni To: mchehab@kernel.org, maurochehab@gmail.com, mchehab@infradead.org, mchehab@redhat.com, m.chehab@samsung.com, ezequiel@vanguardiasur.com.ar, hdegoede@redhat.com, kgene@kernel.org, k.kozlowski@samsung.com Cc: linux-media@vger.kernel.org, linux-kernel@vger.kernel.org, Julia.Lawall@lip6.fr, chuansheng.liu@intel.com, baolex.ni@intel.com Subject: [PATCH 0657/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 19:34:00 +0800 Message-Id: <20160802113400.25850-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/media/usb/ttusb-dec/ttusb_dec.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/media/usb/ttusb-dec/ttusb_dec.c b/drivers/media/usb/ttusb-dec/ttusb_dec.c index 4e36e24..53255b2 100644 --- a/drivers/media/usb/ttusb-dec/ttusb_dec.c +++ b/drivers/media/usb/ttusb-dec/ttusb_dec.c @@ -45,11 +45,11 @@ static int debug; static int output_pva; static int enable_rc; -module_param(debug, int, 0644); +module_param(debug, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(debug, "Turn on/off debugging (default:off)."); -module_param(output_pva, int, 0444); +module_param(output_pva, int, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(output_pva, "Output PVA from dvr device (default:off)"); -module_param(enable_rc, int, 0644); +module_param(enable_rc, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(enable_rc, "Turn on/off IR remote control(default: off)"); DVB_DEFINE_MOD_OPT_ADAPTER_NR(adapter_nr); -- 2.9.2