From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S967332AbcHBQEG (ORCPT ); Tue, 2 Aug 2016 12:04:06 -0400 Received: from mga01.intel.com ([192.55.52.88]:23120 "EHLO mga01.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S934280AbcHBMSb (ORCPT ); Tue, 2 Aug 2016 08:18:31 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="1033588744" From: Baole Ni To: mchehab@kernel.org, maurochehab@gmail.com, mchehab@infradead.org, mchehab@redhat.com, m.chehab@samsung.com, pawel@osciak.com, m.szyprowski@samsung.com, kyungmin.park@samsung.com, k.kozlowski@samsung.com Cc: linux-kernel@vger.kernel.org, akpm@linux-foundation.org, falakreyaz@gmail.com, chuansheng.liu@intel.com, baolex.ni@intel.com Subject: [PATCH 0672/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 19:35:36 +0800 Message-Id: <20160802113536.26865-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/memstick/core/mspro_block.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/memstick/core/mspro_block.c b/drivers/memstick/core/mspro_block.c index 0fb27d3..843c3d12 100644 --- a/drivers/memstick/core/mspro_block.c +++ b/drivers/memstick/core/mspro_block.c @@ -25,7 +25,7 @@ #define DRIVER_NAME "mspro_block" static int major; -module_param(major, int, 0644); +module_param(major, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); #define MSPRO_BLOCK_MAX_SEGS 32 #define MSPRO_BLOCK_MAX_PAGES ((2 << 16) - 1) -- 2.9.2