From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S934330AbcHBQGh (ORCPT ); Tue, 2 Aug 2016 12:06:37 -0400 Received: from mga03.intel.com ([134.134.136.65]:25848 "EHLO mga03.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S933971AbcHBMSG (ORCPT ); Tue, 2 Aug 2016 08:18:06 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="1006951739" From: Baole Ni To: oakad@yahoo.com, maurochehab@gmail.com, mchehab@infradead.org, mchehab@redhat.com, m.chehab@samsung.com, pawel@osciak.com, m.szyprowski@samsung.com, kyungmin.park@samsung.com, k.kozlowski@samsung.com Cc: linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com Subject: [PATCH 0674/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 19:35:47 +0800 Message-Id: <20160802113547.26999-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/memstick/host/tifm_ms.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/memstick/host/tifm_ms.c b/drivers/memstick/host/tifm_ms.c index 7bafa72..dd474a9 100644 --- a/drivers/memstick/host/tifm_ms.c +++ b/drivers/memstick/host/tifm_ms.c @@ -23,7 +23,7 @@ #define DRIVER_NAME "tifm_ms" static bool no_dma; -module_param(no_dma, bool, 0644); +module_param(no_dma, bool, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); /* * Some control bits of TIFM appear to conform to Sony's reference design, -- 2.9.2