From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S934242AbcHBMSr (ORCPT ); Tue, 2 Aug 2016 08:18:47 -0400 Received: from mga11.intel.com ([192.55.52.93]:56451 "EHLO mga11.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S934373AbcHBMS2 (ORCPT ); Tue, 2 Aug 2016 08:18:28 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="1018213776" From: Baole Ni To: sivanich@sgi.com, gregkh@linuxfoundation.org, jirislaby@gmail.com, mchehab@redhat.com, m.chehab@samsung.com, pawel@osciak.com, m.szyprowski@samsung.com, kyungmin.park@samsung.com, k.kozlowski@samsung.com Cc: linux-kernel@vger.kernel.org, robh@kernel.org, daniel.wagner@bmw-carit.de, j@bitron.ch, chuansheng.liu@intel.com, baolex.ni@intel.com Subject: [PATCH 0690/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 19:37:04 +0800 Message-Id: <20160802113704.28062-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/misc/ti-st/st_kim.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/misc/ti-st/st_kim.c b/drivers/misc/ti-st/st_kim.c index bf0d770..2e11441 100644 --- a/drivers/misc/ti-st/st_kim.c +++ b/drivers/misc/ti-st/st_kim.c @@ -639,14 +639,14 @@ static struct kobj_attribute uart_dev_name = #ifdef DEBUG /* TODO: move this to debug-fs if possible */ __ATTR(dev_name, 0644, (void *)show_dev_name, (void *)store_dev_name); #else -__ATTR(dev_name, 0444, (void *)show_dev_name, NULL); +__ATTR(dev_name, S_IRUSR | S_IRGRP | S_IROTH, (void *)show_dev_name, NULL); #endif static struct kobj_attribute uart_baud_rate = #ifdef DEBUG /* TODO: move to debugfs */ __ATTR(baud_rate, 0644, (void *)show_baud_rate, (void *)store_baud_rate); #else -__ATTR(baud_rate, 0444, (void *)show_baud_rate, NULL); +__ATTR(baud_rate, S_IRUSR | S_IRGRP | S_IROTH, (void *)show_baud_rate, NULL); #endif static struct kobj_attribute uart_flow_cntrl = -- 2.9.2