From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S934948AbcHBPzc (ORCPT ); Tue, 2 Aug 2016 11:55:32 -0400 Received: from mga11.intel.com ([192.55.52.93]:10577 "EHLO mga11.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S934573AbcHBMUm (ORCPT ); Tue, 2 Aug 2016 08:20:42 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="858125682" From: Baole Ni To: saschasommer@freenet.de, ulf.hansson@linaro.org, jirislaby@gmail.com, mchehab@redhat.com, m.chehab@samsung.com, pawel@osciak.com, m.szyprowski@samsung.com, kyungmin.park@samsung.com, k.kozlowski@samsung.com Cc: linux-mmc@vger.kernel.org, linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com, jonathanh@nvidia.com, grundler@chromium.org, lporzio@micron.com Subject: [PATCH 0694/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 19:37:27 +0800 Message-Id: <20160802113727.28329-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/mmc/host/sdricoh_cs.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/mmc/host/sdricoh_cs.c b/drivers/mmc/host/sdricoh_cs.c index 5ff26ab..63f05e0 100644 --- a/drivers/mmc/host/sdricoh_cs.c +++ b/drivers/mmc/host/sdricoh_cs.c @@ -538,7 +538,7 @@ static struct pcmcia_driver sdricoh_driver = { }; module_pcmcia_driver(sdricoh_driver); -module_param(switchlocked, uint, 0444); +module_param(switchlocked, uint, S_IRUSR | S_IRGRP | S_IROTH); MODULE_AUTHOR("Sascha Sommer "); MODULE_DESCRIPTION("Ricoh PCMCIA Secure Digital Interface driver"); -- 2.9.2