From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S934250AbcHBMSh (ORCPT ); Tue, 2 Aug 2016 08:18:37 -0400 Received: from mga01.intel.com ([192.55.52.88]:4095 "EHLO mga01.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S934284AbcHBMRf (ORCPT ); Tue, 2 Aug 2016 08:17:35 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="1018214356" From: Baole Ni To: boris.brezillon@free-electrons.com, richard@nod.at, dwmw2@infradead.org, computersforpeace@gmail.com, m.chehab@samsung.com, pawel@osciak.com, m.szyprowski@samsung.com, kyungmin.park@samsung.com, k.kozlowski@samsung.com Cc: linux-mtd@lists.infradead.org, linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com, grundler@chromium.org, lporzio@micron.com Subject: [PATCH 0702/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 19:38:09 +0800 Message-Id: <20160802113809.28857-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/mtd/nand/cafe_nand.c | 12 ++++++------ 1 file changed, 6 insertions(+), 6 deletions(-) diff --git a/drivers/mtd/nand/cafe_nand.c b/drivers/mtd/nand/cafe_nand.c index 0b0c937..20f7abb 100644 --- a/drivers/mtd/nand/cafe_nand.c +++ b/drivers/mtd/nand/cafe_nand.c @@ -72,23 +72,23 @@ struct cafe_priv { }; static int usedma = 1; -module_param(usedma, int, 0644); +module_param(usedma, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); static int skipbbt = 0; -module_param(skipbbt, int, 0644); +module_param(skipbbt, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); static int debug = 0; -module_param(debug, int, 0644); +module_param(debug, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); static int regdebug = 0; -module_param(regdebug, int, 0644); +module_param(regdebug, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); static int checkecc = 1; -module_param(checkecc, int, 0644); +module_param(checkecc, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); static unsigned int numtimings; static int timing[3]; -module_param_array(timing, int, &numtimings, 0644); +module_param_array(timing, int, &numtimings, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); static const char *part_probes[] = { "cmdlinepart", "RedBoot", NULL }; -- 2.9.2