From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S967866AbcHBQUr (ORCPT ); Tue, 2 Aug 2016 12:20:47 -0400 Received: from mga04.intel.com ([192.55.52.120]:51141 "EHLO mga04.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S934275AbcHBMRf (ORCPT ); Tue, 2 Aug 2016 08:17:35 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="858126305" From: Baole Ni To: ezequiel.garcia@free-electrons.com, boris.brezillon@free-electrons.com, richard@nod.at, dwmw2@infradead.org, computersforpeace@gmail.com, m.chehab@samsung.com, pawel@osciak.com, m.szyprowski@samsung.com, kyungmin.park@samsung.com, k.kozlowski@samsung.com Cc: linux-mtd@lists.infradead.org, linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com, grundler@chromium.org, lporzio@micron.com Subject: [PATCH 0704/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 19:38:18 +0800 Message-Id: <20160802113818.28989-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/mtd/nand/pxa3xx_nand.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/mtd/nand/pxa3xx_nand.c b/drivers/mtd/nand/pxa3xx_nand.c index 436dd6d..a5896b8 100644 --- a/drivers/mtd/nand/pxa3xx_nand.c +++ b/drivers/mtd/nand/pxa3xx_nand.c @@ -283,7 +283,7 @@ struct pxa3xx_nand_info { }; static bool use_dma = 1; -module_param(use_dma, bool, 0444); +module_param(use_dma, bool, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(use_dma, "enable DMA for data transferring to/from NAND HW"); struct pxa3xx_nand_timing { -- 2.9.2