From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S935413AbcHBQTu (ORCPT ); Tue, 2 Aug 2016 12:19:50 -0400 Received: from mga03.intel.com ([134.134.136.65]:42919 "EHLO mga03.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S934291AbcHBMRf (ORCPT ); Tue, 2 Aug 2016 08:17:35 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="149312431" From: Baole Ni To: kyungmin.park@samsung.com, dwmw2@infradead.org, computersforpeace@gmail.com, m.chehab@samsung.com, pawel@osciak.com, m.szyprowski@samsung.com, k.kozlowski@samsung.com Cc: linux-mtd@lists.infradead.org, linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com, grundler@chromium.org, lporzio@micron.com Subject: [PATCH 0705/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 19:38:24 +0800 Message-Id: <20160802113824.29055-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/mtd/onenand/onenand_base.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/mtd/onenand/onenand_base.c b/drivers/mtd/onenand/onenand_base.c index a4b029a..7f944e6 100644 --- a/drivers/mtd/onenand/onenand_base.c +++ b/drivers/mtd/onenand/onenand_base.c @@ -44,7 +44,7 @@ /* Default Flex-OneNAND boundary and lock respectively */ static int flex_bdry[MAX_DIES * 2] = { -1, 0, -1, 0 }; -module_param_array(flex_bdry, int, NULL, 0400); +module_param_array(flex_bdry, int, NULL, S_IRUSR); MODULE_PARM_DESC(flex_bdry, "SLC Boundary information for Flex-OneNAND" "Syntax:flex_bdry=DIE_BDRY,LOCK,..." "DIE_BDRY: SLC boundary of the die" @@ -55,7 +55,7 @@ MODULE_PARM_DESC(flex_bdry, "SLC Boundary information for Flex-OneNAND" /* Default OneNAND/Flex-OneNAND OTP options*/ static int otp; -module_param(otp, int, 0400); +module_param(otp, int, S_IRUSR); MODULE_PARM_DESC(otp, "Corresponding behaviour of OneNAND in OTP" "Syntax : otp=LOCK_TYPE" "LOCK_TYPE : Keys issued, for specific OTP Lock type" -- 2.9.2