From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S967462AbcHBPa5 (ORCPT ); Tue, 2 Aug 2016 11:30:57 -0400 Received: from mga02.intel.com ([134.134.136.20]:51345 "EHLO mga02.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S934785AbcHBM3H (ORCPT ); Tue, 2 Aug 2016 08:29:07 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="1006959703" From: Baole Ni To: konrad.wilk@oracle.com, boris.ostrovsky@oracle.com, david.vrabel@citrix.com, jgross@suse.com, bhelgaas@google.com, m.chehab@samsung.com, pawel@osciak.com, m.szyprowski@samsung.com, kyungmin.park@samsung.com, k.kozlowski@samsung.com Cc: linux-pcmcia@lists.infradead.org, linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com Subject: [PATCH 0837/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 19:51:18 +0800 Message-Id: <20160802115118.5793-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/pcmcia/yenta_socket.c | 8 ++++---- 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/drivers/pcmcia/yenta_socket.c b/drivers/pcmcia/yenta_socket.c index 5d6d9b1..1fa8ead 100644 --- a/drivers/pcmcia/yenta_socket.c +++ b/drivers/pcmcia/yenta_socket.c @@ -25,19 +25,19 @@ #include "i82365.h" static bool disable_clkrun; -module_param(disable_clkrun, bool, 0444); +module_param(disable_clkrun, bool, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(disable_clkrun, "If PC card doesn't function properly, please try this option"); static bool isa_probe = 1; -module_param(isa_probe, bool, 0444); +module_param(isa_probe, bool, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(isa_probe, "If set ISA interrupts are probed (default). Set to N to disable probing"); static bool pwr_irqs_off; -module_param(pwr_irqs_off, bool, 0644); +module_param(pwr_irqs_off, bool, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(pwr_irqs_off, "Force IRQs off during power-on of slot. Use only when seeing IRQ storms!"); static char o2_speedup[] = "default"; -module_param_string(o2_speedup, o2_speedup, sizeof(o2_speedup), 0444); +module_param_string(o2_speedup, o2_speedup, sizeof(o2_speedup), S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(o2_speedup, "Use prefetch/burst for O2-bridges: 'on', 'off' " "or 'default' (uses recommended behaviour for the detected bridge)"); -- 2.9.2