From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S966275AbcHBPPe (ORCPT ); Tue, 2 Aug 2016 11:15:34 -0400 Received: from mga14.intel.com ([192.55.52.115]:46508 "EHLO mga14.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S965066AbcHBMeu (ORCPT ); Tue, 2 Aug 2016 08:34:50 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="1033598480" From: Baole Ni To: maier@linux.vnet.ibm.com, schwidefsky@de.ibm.com, heiko.carstens@de.ibm.com, dwmw2@infradead.org, m.chehab@samsung.com, pawel@osciak.com, m.szyprowski@samsung.com, kyungmin.park@samsung.com, k.kozlowski@samsung.com Cc: linux-s390@vger.kernel.org, linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com Subject: [PATCH 0899/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 19:56:19 +0800 Message-Id: <20160802115619.9907-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/s390/scsi/zfcp_aux.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/s390/scsi/zfcp_aux.c b/drivers/s390/scsi/zfcp_aux.c index c00ac46..bf3fbe2 100644 --- a/drivers/s390/scsi/zfcp_aux.c +++ b/drivers/s390/scsi/zfcp_aux.c @@ -44,7 +44,7 @@ MODULE_DESCRIPTION("FCP HBA driver"); MODULE_LICENSE("GPL"); static char *init_device; -module_param_named(device, init_device, charp, 0400); +module_param_named(device, init_device, charp, S_IRUSR); MODULE_PARM_DESC(device, "specify initial device"); static struct kmem_cache * __init zfcp_cache_hw_align(const char *name, -- 2.9.2