From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S966608AbcHBPCw (ORCPT ); Tue, 2 Aug 2016 11:02:52 -0400 Received: from mga11.intel.com ([192.55.52.93]:39806 "EHLO mga11.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S935082AbcHBMgL (ORCPT ); Tue, 2 Aug 2016 08:36:11 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="1033599446" From: Baole Ni To: gregkh@linuxfoundation.org, jejb@linux.vnet.ibm.com, martin.petersen@oracle.com, m.chehab@samsung.com, pawel@osciak.com, m.szyprowski@samsung.com, kyungmin.park@samsung.com, k.kozlowski@samsung.com Cc: devel@driverdev.osuosl.org, linux-kernel@vger.kernel.org, abbotti@mev.co.uk, hsweeten@visionengravers.com, ranjithece24@gmail.com, chuansheng.liu@intel.com, baolex.ni@intel.com Subject: [PATCH 0922/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 19:58:13 +0800 Message-Id: <20160802115813.11460-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/staging/comedi/drivers/ni_65xx.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/comedi/drivers/ni_65xx.c b/drivers/staging/comedi/drivers/ni_65xx.c index 251117b..fd73efa 100644 --- a/drivers/staging/comedi/drivers/ni_65xx.c +++ b/drivers/staging/comedi/drivers/ni_65xx.c @@ -271,7 +271,7 @@ static const struct ni_65xx_board ni_65xx_boards[] = { static bool ni_65xx_legacy_invert_outputs; module_param_named(legacy_invert_outputs, ni_65xx_legacy_invert_outputs, - bool, 0444); + bool, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(legacy_invert_outputs, "invert outputs of PCI/PXI-6513/6514/6515/6516/6517/6518/6519 for compatibility with old user code"); -- 2.9.2