From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S965006AbcHBMmL (ORCPT ); Tue, 2 Aug 2016 08:42:11 -0400 Received: from mga11.intel.com ([192.55.52.93]:49182 "EHLO mga11.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S935126AbcHBMjC (ORCPT ); Tue, 2 Aug 2016 08:39:02 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="1006964642" From: Baole Ni To: mchehab@kernel.org, maurochehab@gmail.com, mchehab@infradead.org, mchehab@redhat.com, m.chehab@samsung.com, gregkh@linuxfoundation.org, m.szyprowski@samsung.com, kyungmin.park@samsung.com, k.kozlowski@samsung.com Cc: linux-media@vger.kernel.org, devel@driverdev.osuosl.org, linux-kernel@vger.kernel.org, amitoj1606@gmail.com, Julia.Lawall@lip6.fr, thaissa.falbo@gmail.com, chuansheng.liu@intel.com, baolex.ni@intel.com Subject: [PATCH 0945/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 20:01:20 +0800 Message-Id: <20160802120120.13030-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/staging/media/davinci_vpfe/vpfe_mc_capture.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/media/davinci_vpfe/vpfe_mc_capture.c b/drivers/staging/media/davinci_vpfe/vpfe_mc_capture.c index bf077f8..a952fd6 100644 --- a/drivers/staging/media/davinci_vpfe/vpfe_mc_capture.c +++ b/drivers/staging/media/davinci_vpfe/vpfe_mc_capture.c @@ -75,7 +75,7 @@ static bool debug; static bool interface; module_param(interface, bool, S_IRUGO); -module_param(debug, bool, 0644); +module_param(debug, bool, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); /** * VPFE capture can be used for capturing video such as from TVP5146 or TVP7002 -- 2.9.2