From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S935299AbcHBOpI (ORCPT ); Tue, 2 Aug 2016 10:45:08 -0400 Received: from mga11.intel.com ([192.55.52.93]:57290 "EHLO mga11.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S965033AbcHBMnI (ORCPT ); Tue, 2 Aug 2016 08:43:08 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="858143973" From: Baole Ni To: gregkh@linuxfoundation.org, jslaby@suse.com, m.chehab@samsung.com, m.szyprowski@samsung.com, kyungmin.park@samsung.com, k.kozlowski@samsung.com Cc: linux-serial@vger.kernel.org, linux-kernel@vger.kernel.org, phillip.raffeck@fau.de, anton.wuerfel@fau.de, andriy.shevchenko@linux.intel.com, chuansheng.liu@intel.com, baolex.ni@intel.com, wan.ahmad.zainie.wan.mohamad@intel.com, mail@maciej.szmigiero.name, matwey@sai.msu.ru Subject: [PATCH 0968/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 20:03:39 +0800 Message-Id: <20160802120339.14595-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/tty/serial/8250/serial_cs.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/tty/serial/8250/serial_cs.c b/drivers/tty/serial/8250/serial_cs.c index 933c268..6778d81 100644 --- a/drivers/tty/serial/8250/serial_cs.c +++ b/drivers/tty/serial/8250/serial_cs.c @@ -60,8 +60,8 @@ static int do_sound = 1; /* Skip strict UART tests? */ static int buggy_uart; -module_param(do_sound, int, 0444); -module_param(buggy_uart, int, 0444); +module_param(do_sound, int, S_IRUSR | S_IRGRP | S_IROTH); +module_param(buggy_uart, int, S_IRUSR | S_IRGRP | S_IROTH); /*====================================================================*/ -- 2.9.2