From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S966053AbcHBNAv (ORCPT ); Tue, 2 Aug 2016 09:00:51 -0400 Received: from mga04.intel.com ([192.55.52.120]:61228 "EHLO mga04.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S965922AbcHBNAb (ORCPT ); Tue, 2 Aug 2016 09:00:31 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="1018230177" From: Baole Ni To: plagnioj@jcrosoft.com, tomi.valkeinen@ti.com, m.chehab@samsung.com, gregkh@linuxfoundation.org, m.szyprowski@samsung.com, kyungmin.park@samsung.com, k.kozlowski@samsung.com Cc: linux-fbdev@vger.kernel.org, linux-kernel@vger.kernel.org, arnd@arndb.de, chuansheng.liu@intel.com, baolex.ni@intel.com, mathias.nyman@linux.intel.com, stern@rowland.harvard.edu, oneukum@suse.com Subject: [PATCH 0999/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 20:06:45 +0800 Message-Id: <20160802120645.16675-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/video/fbdev/auo_k190x.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/video/fbdev/auo_k190x.c b/drivers/video/fbdev/auo_k190x.c index 9580374..7e62a38 100644 --- a/drivers/video/fbdev/auo_k190x.c +++ b/drivers/video/fbdev/auo_k190x.c @@ -707,9 +707,9 @@ static ssize_t temp_show(struct device *dev, struct device_attribute *attr, return sprintf(buf, "%d\n", temp); } -static DEVICE_ATTR(update_mode, 0644, update_mode_show, update_mode_store); -static DEVICE_ATTR(flash, 0644, flash_show, flash_store); -static DEVICE_ATTR(temp, 0644, temp_show, NULL); +static DEVICE_ATTR(update_mode, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH, update_mode_show, update_mode_store); +static DEVICE_ATTR(flash, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH, flash_show, flash_store); +static DEVICE_ATTR(temp, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH, temp_show, NULL); static struct attribute *auok190x_attributes[] = { &dev_attr_update_mode.attr, -- 2.9.2