From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S965355AbcHBMtv (ORCPT ); Tue, 2 Aug 2016 08:49:51 -0400 Received: from mga03.intel.com ([134.134.136.65]:32531 "EHLO mga03.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S935130AbcHBMph (ORCPT ); Tue, 2 Aug 2016 08:45:37 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="1033604274" From: Baole Ni To: plagnioj@jcrosoft.com, tomi.valkeinen@ti.com, m.chehab@samsung.com, gregkh@linuxfoundation.org, m.szyprowski@samsung.com, kyungmin.park@samsung.com, k.kozlowski@samsung.com Cc: linux-geode@lists.infradead.org, linux-fbdev@vger.kernel.org, linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com, linus.walleij@linaro.org, oneukum@suse.com Subject: [PATCH 1008/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 20:07:46 +0800 Message-Id: <20160802120746.17287-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/video/fbdev/geode/gx1fb_core.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/video/fbdev/geode/gx1fb_core.c b/drivers/video/fbdev/geode/gx1fb_core.c index 9bee874..51f70e3 100644 --- a/drivers/video/fbdev/geode/gx1fb_core.c +++ b/drivers/video/fbdev/geode/gx1fb_core.c @@ -461,13 +461,13 @@ static void gx1fb_cleanup(void) module_init(gx1fb_init); module_exit(gx1fb_cleanup); -module_param_string(mode, mode_option, sizeof(mode_option), 0444); +module_param_string(mode, mode_option, sizeof(mode_option), S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(mode, "video mode (x[-][@])"); -module_param_named(crt, crt_option, int, 0444); +module_param_named(crt, crt_option, int, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(crt, "enable CRT output. 0 = off, 1 = on (default)"); -module_param_string(panel, panel_option, sizeof(panel_option), 0444); +module_param_string(panel, panel_option, sizeof(panel_option), S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(panel, "size of attached flat panel (x)"); MODULE_DESCRIPTION("framebuffer driver for the AMD Geode GX1"); -- 2.9.2