From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S932546AbcHBOR3 (ORCPT ); Tue, 2 Aug 2016 10:17:29 -0400 Received: from mga09.intel.com ([134.134.136.24]:27534 "EHLO mga09.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S965675AbcHBMxp (ORCPT ); Tue, 2 Aug 2016 08:53:45 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="858149610" From: Baole Ni To: boris.ostrovsky@oracle.com, david.vrabel@citrix.com, jgross@suse.com, tomi.valkeinen@ti.com, m.chehab@samsung.com, gregkh@linuxfoundation.org, m.szyprowski@samsung.com, kyungmin.park@samsung.com, k.kozlowski@samsung.com Cc: xen-devel@lists.xenproject.org, linux-kernel@vger.kernel.org, stefano.stabellini@eu.citrix.com, paul.gortmaker@windriver.com, chuansheng.liu@intel.com, baolex.ni@intel.com, oneukum@suse.com Subject: [PATCH 1032/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 20:10:08 +0800 Message-Id: <20160802121008.18908-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/xen/xen-pciback/conf_space.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/xen/xen-pciback/conf_space.c b/drivers/xen/xen-pciback/conf_space.c index 8e67336..e1fb906 100644 --- a/drivers/xen/xen-pciback/conf_space.c +++ b/drivers/xen/xen-pciback/conf_space.c @@ -17,7 +17,7 @@ #include "conf_space_quirks.h" bool xen_pcibk_permissive; -module_param_named(permissive, xen_pcibk_permissive, bool, 0644); +module_param_named(permissive, xen_pcibk_permissive, bool, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); /* This is where xen_pcibk_read_config_byte, xen_pcibk_read_config_word, * xen_pcibk_write_config_word, and xen_pcibk_write_config_byte are created. */ -- 2.9.2