From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S965733AbcHBMyN (ORCPT ); Tue, 2 Aug 2016 08:54:13 -0400 Received: from mga09.intel.com ([134.134.136.24]:2284 "EHLO mga09.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S965658AbcHBMxb (ORCPT ); Tue, 2 Aug 2016 08:53:31 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="1028287408" From: Baole Ni To: boris.ostrovsky@oracle.com, david.vrabel@citrix.com, jgross@suse.com, tomi.valkeinen@ti.com, m.chehab@samsung.com, gregkh@linuxfoundation.org, m.szyprowski@samsung.com, kyungmin.park@samsung.com, k.kozlowski@samsung.com Cc: xen-devel@lists.xenproject.org, linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com, oneukum@suse.com Subject: [PATCH 1033/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 20:10:15 +0800 Message-Id: <20160802121015.18976-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/xen/xen-pciback/pci_stub.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/xen/xen-pciback/pci_stub.c b/drivers/xen/xen-pciback/pci_stub.c index 258b7c3..cf67c9c 100644 --- a/drivers/xen/xen-pciback/pci_stub.c +++ b/drivers/xen/xen-pciback/pci_stub.c @@ -31,7 +31,7 @@ wait_queue_head_t xen_pcibk_aer_wait_queue; * We want to avoid in middle of AER ops, xen_pcibk devices is being removed */ static DECLARE_RWSEM(pcistub_sem); -module_param_named(hide, pci_devs_to_hide, charp, 0444); +module_param_named(hide, pci_devs_to_hide, charp, S_IRUSR | S_IRGRP | S_IROTH); struct pcistub_device_id { struct list_head slot_list; -- 2.9.2