From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S965672AbcHBMxi (ORCPT ); Tue, 2 Aug 2016 08:53:38 -0400 Received: from mga11.intel.com ([192.55.52.93]:10152 "EHLO mga11.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S965632AbcHBMxQ (ORCPT ); Tue, 2 Aug 2016 08:53:16 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="743095528" From: Baole Ni To: boris.ostrovsky@oracle.com, david.vrabel@citrix.com, jgross@suse.com, tomi.valkeinen@ti.com, m.chehab@samsung.com, gregkh@linuxfoundation.org, m.szyprowski@samsung.com, kyungmin.park@samsung.com, k.kozlowski@samsung.com Cc: xen-devel@lists.xenproject.org, linux-kernel@vger.kernel.org, konrad.wilk@oracle.com, jbeulich@suse.com, stefano.stabellini@eu.citrix.com, paul.gortmaker@windriver.com, chuansheng.liu@intel.com, baolex.ni@intel.com, oneukum@suse.com Subject: [PATCH 1034/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 20:10:22 +0800 Message-Id: <20160802121022.19044-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/xen/xen-pciback/pciback_ops.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/xen/xen-pciback/pciback_ops.c b/drivers/xen/xen-pciback/pciback_ops.c index 2f19dd7..27e19c2 100644 --- a/drivers/xen/xen-pciback/pciback_ops.c +++ b/drivers/xen/xen-pciback/pciback_ops.c @@ -14,7 +14,7 @@ #include "pciback.h" int verbose_request; -module_param(verbose_request, int, 0644); +module_param(verbose_request, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); static irqreturn_t xen_pcibk_guest_interrupt(int irq, void *dev_id); -- 2.9.2