From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S935220AbcHBOeT (ORCPT ); Tue, 2 Aug 2016 10:34:19 -0400 Received: from mga09.intel.com ([134.134.136.24]:44046 "EHLO mga09.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S965454AbcHBMwK (ORCPT ); Tue, 2 Aug 2016 08:52:10 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="858152196" From: Baole Ni To: jason.wessel@windriver.com, ccross@android.com, keescook@chromium.org, tony.luck@intel.com, tomi.valkeinen@ti.com, m.chehab@samsung.com, gregkh@linuxfoundation.org, m.szyprowski@samsung.com, kyungmin.park@samsung.com, k.kozlowski@samsung.com Cc: kgdb-bugreport@lists.sourceforge.net, linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com, oleg@redhat.com, akpm@linux-foundation.org, linux@rasmusvillemoes.dk Subject: [PATCH 1062/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 20:12:59 +0800 Message-Id: <20160802121259.20917-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- kernel/debug/debug_core.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/kernel/debug/debug_core.c b/kernel/debug/debug_core.c index 0874e2e..2716f17 100644 --- a/kernel/debug/debug_core.c +++ b/kernel/debug/debug_core.c @@ -102,8 +102,8 @@ static int __init opt_kgdb_con(char *str) early_param("kgdbcon", opt_kgdb_con); -module_param(kgdb_use_con, int, 0644); -module_param(kgdbreboot, int, 0644); +module_param(kgdb_use_con, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); +module_param(kgdbreboot, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); /* * Holds information about breakpoints in a kernel. These breakpoints are -- 2.9.2