From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S934183AbcHBOd5 (ORCPT ); Tue, 2 Aug 2016 10:33:57 -0400 Received: from mga09.intel.com ([134.134.136.24]:48656 "EHLO mga09.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S965455AbcHBMwK (ORCPT ); Tue, 2 Aug 2016 08:52:10 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="1018233210" From: Baole Ni To: jason.wessel@windriver.com, ccross@android.com, keescook@chromium.org, tony.luck@intel.com, tomi.valkeinen@ti.com, m.chehab@samsung.com, gregkh@linuxfoundation.org, m.szyprowski@samsung.com, kyungmin.park@samsung.com, k.kozlowski@samsung.com Cc: kgdb-bugreport@lists.sourceforge.net, linux-kernel@vger.kernel.org, peterz@infradead.org, rusty@rustcorp.com.au, jkosina@suse.cz, chuansheng.liu@intel.com, baolex.ni@intel.com Subject: [PATCH 1063/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 20:13:05 +0800 Message-Id: <20160802121305.20985-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- kernel/debug/kdb/kdb_main.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/kernel/debug/kdb/kdb_main.c b/kernel/debug/kdb/kdb_main.c index 2a20c0d..8c62a67 100644 --- a/kernel/debug/kdb/kdb_main.c +++ b/kernel/debug/kdb/kdb_main.c @@ -48,7 +48,7 @@ #define MODULE_PARAM_PREFIX "kdb." static int kdb_cmd_enabled = CONFIG_KDB_DEFAULT_ENABLE; -module_param_named(cmd_enable, kdb_cmd_enabled, int, 0600); +module_param_named(cmd_enable, kdb_cmd_enabled, int, S_IRUSR | S_IWUSR); char kdb_grep_string[KDB_GREP_STRLEN]; int kdb_grepping_flag; @@ -2183,7 +2183,7 @@ static int kdb_param_enable_nmi(const char *val, const struct kernel_param *kp) static const struct kernel_param_ops kdb_param_ops_enable_nmi = { .set = kdb_param_enable_nmi, }; -module_param_cb(enable_nmi, &kdb_param_ops_enable_nmi, NULL, 0600); +module_param_cb(enable_nmi, &kdb_param_ops_enable_nmi, NULL, S_IRUSR | S_IWUSR); /* * kdb_cpu - This function implements the 'cpu' command. -- 2.9.2