From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S933996AbcHBOVI (ORCPT ); Tue, 2 Aug 2016 10:21:08 -0400 Received: from mga11.intel.com ([192.55.52.93]:49134 "EHLO mga11.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S965363AbcHBMwt (ORCPT ); Tue, 2 Aug 2016 08:52:49 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="1028289436" From: Baole Ni To: ericvh@gmail.com, rminnich@sandia.gov, lucho@ionkov.net, davem@davemloft.net, jiangshanlai@gmail.com, m.chehab@samsung.com, gregkh@linuxfoundation.org, m.szyprowski@samsung.com, kyungmin.park@samsung.com, k.kozlowski@samsung.com Cc: v9fs-developer@lists.sourceforge.net, netdev@vger.kernel.org, linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com, gang.chen.5i5j@gmail.com, mhocko@suse.com, koct9i@gmail.com, aarcange@redhat.com, aryabinin@virtuozzo.com Subject: [PATCH 1085/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 20:15:07 +0800 Message-Id: <20160802121507.22460-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- net/9p/trans_virtio.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/net/9p/trans_virtio.c b/net/9p/trans_virtio.c index 4acb1d5..f5ae921 100644 --- a/net/9p/trans_virtio.c +++ b/net/9p/trans_virtio.c @@ -527,7 +527,7 @@ static ssize_t p9_mount_tag_show(struct device *dev, return chan->tag_len + 1; } -static DEVICE_ATTR(mount_tag, 0444, p9_mount_tag_show, NULL); +static DEVICE_ATTR(mount_tag, S_IRUSR | S_IRGRP | S_IROTH, p9_mount_tag_show, NULL); /** * p9_virtio_probe - probe for existence of 9P virtio channels -- 2.9.2