From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S965777AbcHBM7i (ORCPT ); Tue, 2 Aug 2016 08:59:38 -0400 Received: from mga02.intel.com ([134.134.136.20]:19151 "EHLO mga02.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S965477AbcHBM5v (ORCPT ); Tue, 2 Aug 2016 08:57:51 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="1033609790" From: Baole Ni To: johannes@sipsolutions.net, davem@davemloft.net, linux-wimax@intel.com, anna.schumaker@netapp.com, kadlec@blackhole.kfki.hu, m.szyprowski@samsung.com, kyungmin.park@samsung.com, k.kozlowski@samsung.com Cc: linux-kernel@vger.kernel.org, akpm@linux-foundation.org, shijie.huang@arm.com, pmladek@suse.com, chuansheng.liu@intel.com, baolex.ni@intel.com, aryabinin@virtuozzo.com Subject: [PATCH 1143/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 20:20:07 +0800 Message-Id: <20160802122007.26316-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- samples/kprobes/kprobe_example.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/samples/kprobes/kprobe_example.c b/samples/kprobes/kprobe_example.c index ed0ca0c..bb00dab 100644 --- a/samples/kprobes/kprobe_example.c +++ b/samples/kprobes/kprobe_example.c @@ -16,7 +16,7 @@ #define MAX_SYMBOL_LEN 64 static char symbol[MAX_SYMBOL_LEN] = "_do_fork"; -module_param_string(symbol, symbol, sizeof(symbol), 0644); +module_param_string(symbol, symbol, sizeof(symbol), S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); /* For each probe you need to allocate a kprobe structure */ static struct kprobe kp = { -- 2.9.2